Monday, September 7, 2009

Happy Holiday!

Happy Labor Day, everyone (while you're enjoying that last hot dog of summer, remember that if it weren't for the labor movement, you wouldn't have paid vacations, sick days, emergency exits, weekends, or even bathroom breaks!). I'm using a bit of time this weekend to finally finish processing my photos from the summer travels. Here's the first. We took a roadtrip up to Chicago at the end of July, and our trip didn't start out very well (this is about two hours into our drive):


Happily, this cleared out all the bad juju and the rest of the trip was wonderful... great sights, wonderful food and fantastic company (we visited my brother and his wife). More photos are forthcoming...

2 comments:

tut-tut said...

I can tell you a whale of a tale about moving down here from Mass., and having the UHaul truck not start after spending the night in Virginia. Because the oil filter had never been changed. But we didn't find that out for 24 hours . . .

alice said...

Argh! How frustrating! I haven't been very impressed with U-Haul's equipment in the past and this trip did not change my opinion. As you maybe can see from the photo, this trailer could possibly even predate me! Our flat tire put us behind about two hours, but once we got through the red tape, I have to admit that the local mechanic responded quickly and had us on the road in good time! It was just getting to that point that took a while. Next time, I'll check out a few more rental companies instead of defaulting to U-Haul...